Video test

Test your messages here, beginners welcome..
Post Reply
User avatar
Wicky
Posts: 7591
Joined: Sat Feb 11, 2006 2:43 pm
Location: Colchester Essex
Contact:

Video test

Post by Wicky » Tue Jan 10, 2017 1:01 am

It may be that your whole purpose in life is simply to serve as a warning to others.

User avatar
VTRDark
Posts: 20010
Joined: Sun Mar 18, 2012 9:24 pm

Re: Video test

Post by VTRDark » Tue Jan 10, 2017 2:16 am

==============================Enter the Darkside

User avatar
VTRDark
Posts: 20010
Joined: Sun Mar 18, 2012 9:24 pm

Re: Video test

Post by VTRDark » Tue Jan 10, 2017 2:21 am

Well both videos work for me in Safari, Opera Developer and Epic which are the only browsers I use that I allow Flash on as they are not my everyday general use browsers.
==============================Enter the Darkside

User avatar
Wicky
Posts: 7591
Joined: Sat Feb 11, 2006 2:43 pm
Location: Colchester Essex
Contact:

Re: Video test

Post by Wicky » Tue Jan 10, 2017 8:01 am

Still odd

Code: Select all

https://www.vtr1000.org/phpBB3/viewtopic.php?f=15&t=40372&p=436865#p436865
viewtopic.php?f=15&t=40372&p=436865#p436865

Image

Code: Select all

http://www.vtr1000.org/phpBB3/viewtopic.php?f=15&t=40372&p=436865#p436865
viewtopic.php?f=15&t=40372&p=436865#p436865

Image
Last edited by Wicky on Tue Jan 10, 2017 8:52 am, edited 1 time in total.
It may be that your whole purpose in life is simply to serve as a warning to others.

User avatar
Wicky
Posts: 7591
Joined: Sat Feb 11, 2006 2:43 pm
Location: Colchester Essex
Contact:

Re: Video test

Post by Wicky » Tue Jan 10, 2017 8:45 am

Digging round in Develop mode in Safari and errors - I get hidden away error > [Warning] [blocked] The page at about:blank was not allowed to display insecure content from http://www.youtube.com/embed/IDENTIFIER.

'This with the VTR forum page being https trying to show youtube vids edited to be http (from https)

Then when I reload the VTR page as http the vids work - which points at a mixed mode error with https and http.

Same behaviour in Safari 10.0.2, Firefox 50.1.0, and Chrome 55.0.2883.95

So it seems while viewing the VTR site in https secure mode it will block any embedded 'insecure' http content. As forum's plus-in / extension for showing embeded https video doesn't function - hence the old hack having to edit the 's' out to get it play nice even in http mode.

And this odd behaviour I now recall started when the site was made https.

Problem > Embedding youtube http or https > https://www.phpbb.com/community/viewtop ... &t=2182570

Solution > BBcode for Youtube videos in phpBB3 3.1.1 > https://www.phpbb.com/community/viewtop ... p=13839826
It may be that your whole purpose in life is simply to serve as a warning to others.

User avatar
VTRDark
Posts: 20010
Joined: Sun Mar 18, 2012 9:24 pm

Re: Video test

Post by VTRDark » Tue Jan 10, 2017 3:01 pm

Argh I see the issue is with the mixed content. I don't think things have been setup quite right on the https side of things and certificate. External content should show and play but as we have no control over external content it should show up as mixed content ie non https or it could even be the browser itself blocking mixed content over https.

https://support.mozilla.org/en-US/kb/mi ... ng-firefox

https://www.keycdn.com/support/mixed-content/
==============================Enter the Darkside

User avatar
j4weeson
Posts: 50
Joined: Wed Aug 03, 2016 1:20 pm

Re: Video test

Post by j4weeson » Fri Feb 03, 2017 2:25 pm


User avatar
j4weeson
Posts: 50
Joined: Wed Aug 03, 2016 1:20 pm

Re: Video test

Post by j4weeson » Tue Jul 04, 2017 7:48 am


Post Reply