Regulator / Rectifier Modification

Where all the workshop knowledge lives together.
User avatar
Zakalwe
Posts: 567
Joined: Sun Sep 17, 2006 11:22 am
Location: Lancaster

Regulator/Rectifiers

Post by Zakalwe » Wed Oct 18, 2006 9:24 am

The later Storms appear to have a bigger R/R fitted with cooling fins.

Do these still blow and should be replaced with a Yam one (preventative maintenance....mine is OK at the mo)?

User avatar
streetf2
Posts: 61
Joined: Mon Jan 22, 2007 9:01 pm

Post by streetf2 » Sun Feb 18, 2007 9:13 pm

yes please does anyone know if the later honda one with cooling fins on still blow as i have one of these on my old storm! someone else must of had this problem on my old bike.
If it aint fixed don't break it.

Beast
Posts: 232
Joined: Sun Apr 25, 2004 7:49 pm
Location: Brighton, UK

Post by Beast » Mon Feb 19, 2007 9:46 pm

As far as i know, the newer R/R's which include the built in heat sink are safe.
This mod is for those that do not have the newer unit and to save money. ;)

User avatar
olkno9
Posts: 49
Joined: Thu Dec 16, 2004 11:39 pm
Location: Yorkshire
Contact:

Post by olkno9 » Sun Mar 25, 2007 9:16 pm

I notice on the link at begining of this that the red and green wires are diffrent way round on the Honda to the yamaha is this right, dont want to blow anything up. cheers

User avatar
LotusSevenMan
Posts: 1915
Joined: Wed Sep 06, 2006 7:32 pm
Location: Liss, Hampshire. UK

Post by LotusSevenMan » Sun Mar 25, 2007 9:56 pm

Image

Follow this scheme and it'll work fine.
Mine is seen below. You can see how the wires go quite clearly. I didn't move the relay from its original place as can be seen and it is all OK like this.

Image

Good luck :wink:
"Only ride as fast as your guardian angel can fly" !!!

User avatar
olkno9
Posts: 49
Joined: Thu Dec 16, 2004 11:39 pm
Location: Yorkshire
Contact:

Post by olkno9 » Sun Mar 25, 2007 10:03 pm

cheers will hopefully get sorted for the good weather coming.

User avatar
olkno9
Posts: 49
Joined: Thu Dec 16, 2004 11:39 pm
Location: Yorkshire
Contact:

Post by olkno9 » Mon Mar 26, 2007 11:10 pm

got the yammy r/r on fired up ok then just cut out. tried it a few times and sometimes it ran others it just died, looks like either the battery went when i had my problems before or theirs a cable from battery earthing and draining power, 1 time it fires ok other time it just clicks like no charge, then it fires up again. had the tester on it and the battery was charging when it run but it suddenly would drop from around 14 volts to 13.7 for no reason, hope ill be sorted soon.

User avatar
VeetyR
Posts: 334
Joined: Thu Feb 15, 2007 7:46 am
Location: London

Post by VeetyR » Tue Mar 27, 2007 6:20 am

This is a common problem.......when i had my old 400cc superfour i used to come across it a lot in 400greybike forums.......it affects the 400's quite badly.......anyway to cut a long story short.....there is another modification u can do to the stock R/R and its quite simple and i sont see why it shouldnt work on the storm......

All u gotta do is source some ali heatsinks for pc memory like these....

Image

mount them onto your R/R and away you go .... instant heat disipitation which counters the cause of your R/R failing. VeetyR(john'o)
Keep it gutter...Keep it grimey..........one!

User avatar
alan
Posts: 1349
Joined: Tue Mar 07, 2006 1:22 am
Location: leeds
Contact:

Post by alan » Tue Mar 27, 2007 12:51 pm

Yeah veetyr its been done like this already but with a heatsink fan from a pc.

User avatar
sirch345
Site Admin
Posts: 16620
Joined: Mon Aug 25, 2003 9:35 pm
Location: Cornwall, UK

Post by sirch345 » Tue Mar 27, 2007 1:33 pm

alan wrote:Yeah veetyr its been done like this already but with a heatsink fan from a pc.
See link:- http://www.burniemorgan.com/firestorm/reg_heatsink.html
A closed mouth gathers no foot. :thumbup:

ImageImageImage

User avatar
RedStormV
Posts: 1372
Joined: Thu Jun 07, 2007 8:41 pm
Location: West Yorks (Bronte Country) - Home of the Negro Lesbian Cornet Players
Contact:

Post by RedStormV » Mon Jun 11, 2007 7:58 pm

Hi,

This post is how I found this site and very grateful I am too! :D

After 3rd R/R failure and 2nd fried battery (they get upset when you pump just under 18V into them) I was getting desparate to find an alternative. :cry:

I'd even contemplated paying approx £50 for one off e-bay and visiting Maplins for some heat sink compound and a heatsink, shaping it to fit R/R and compounding it to the subframe!!!! :x

Went to Rufforth Saturday before last and spied an R6 R/R, she wanted £15 but took £10 when I told her it was only for an experiment - LOL :lol:

Only difference between this mod and mine is that I didn't want to chop my wiring harness, so I made up a patch lead (3"-4") with suitable wire and connectors (soldered rather than crimped of course) to go between the harness plug and the new R/R.

One advantage to this is that you don't have to move the flasher relay.

All is fine at present getting a nice voltage between 14 and 15 V.

Cheers

Graeme
Image

User avatar
sparrowlegs
Posts: 668
Joined: Sun Apr 16, 2006 6:08 pm
Location: lancs
Contact:

Post by sparrowlegs » Sun Aug 05, 2007 7:28 pm

Anyone used a reg rec of a VFR750...one of the oldest ones.....seen this one on Ebay and wondered if it would do the trick..as mine decided to commit hari kiri today going up to Devils bridge.....ended up sat at the side of the road for nearly 2 hrs waitin for the RAC lol...got a nice tan anyway :lol:
Image

User avatar
sparrowlegs
Posts: 668
Joined: Sun Apr 16, 2006 6:08 pm
Location: lancs
Contact:

Post by sparrowlegs » Mon Aug 06, 2007 8:55 pm

been out into the garage and robbed the R/R off the hubbies Storm..coz he's not using his this week and i need mine....and i got a nice surprise...his bike has the standard R/R on it...but some clever person has put a pc heat sink on the stock item and used compound on the back of it and on the frame.....me thinks who ever had the bike before him must've used this site !!!!!! Previous ovmer of our second storm...we salute you :D :D :D :D :D :D :D
Image

User avatar
Stormin Ben
Posts: 1234
Joined: Sun Dec 01, 2002 12:23 am
Location: Birmingham

Post by Stormin Ben » Wed Aug 08, 2007 10:33 am

Redstorm,
Either you've been very unlucky with reg/recs or there's some underlying problem causing them to fail prematurely

Make sure the connection where the reg bolts onto the frame & also the earth strap is really clean and free from muck/ rust etc
If this is dirty it doesnt earth properly and goes tilt
I've got an inferiority complex
But its not a very good one!

User avatar
RedStormV
Posts: 1372
Joined: Thu Jun 07, 2007 8:41 pm
Location: West Yorks (Bronte Country) - Home of the Negro Lesbian Cornet Players
Contact:

Post by RedStormV » Tue Oct 23, 2007 10:08 am

No Ben,

All earthing was fine.

Anywho, just posted this in reply to another thread thought it might be helpful on here:

You can get R1 or R6 R/R from autojumbles ie Rufforth / Newark for £10-£15 and it's a simple mod to change.

IMO don't put another Honda one on - unreliable, although one with heatsink is going to fair better cos of cooling effect.

Alternatively if your stock one is OK, got to Maplins or RS componenets or similar, buy:
  • Small piece of heatsink (or take one off an old PC processor).
    Tube or sachet of heatsink compound (white paste).

    Cut the heatsink to fit around the shape of the R/R (metal surround).
    Drill two holes through to match the R/R ones.
    Blather the base of the heatsink in compound so it fills the void.
    Screw assembly back in place.
    (PC heatsinks are VERY efficient)
Robert's your Fathers' Brother


HTH

Graeme.

*
Image

Post Reply